Re: [PATCH 3/3] xfs: remove the t_magic field in struct xfs_trans

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Jan 06, 2025 at 10:50:31AM +0100, Christoph Hellwig wrote:
> The t_magic field is only ever assigned to, but never read.  Remove it.
> 
> Signed-off-by: Christoph Hellwig <hch@xxxxxx>

And it eliminates a 4-byte hole!

Reviewed-by: "Darrick J. Wong" <djwong@xxxxxxxxxx>

--D

> ---
>  fs/xfs/xfs_trans.c | 2 --
>  fs/xfs/xfs_trans.h | 1 -
>  2 files changed, 3 deletions(-)
> 
> diff --git a/fs/xfs/xfs_trans.c b/fs/xfs/xfs_trans.c
> index 4cd25717c9d1..786fb659ee3f 100644
> --- a/fs/xfs/xfs_trans.c
> +++ b/fs/xfs/xfs_trans.c
> @@ -100,7 +100,6 @@ xfs_trans_dup(
>  	/*
>  	 * Initialize the new transaction structure.
>  	 */
> -	ntp->t_magic = XFS_TRANS_HEADER_MAGIC;
>  	ntp->t_mountp = tp->t_mountp;
>  	INIT_LIST_HEAD(&ntp->t_items);
>  	INIT_LIST_HEAD(&ntp->t_busy);
> @@ -275,7 +274,6 @@ xfs_trans_alloc(
>  	ASSERT(!(flags & XFS_TRANS_RES_FDBLKS) ||
>  	       xfs_has_lazysbcount(mp));
>  
> -	tp->t_magic = XFS_TRANS_HEADER_MAGIC;
>  	tp->t_flags = flags;
>  	tp->t_mountp = mp;
>  	INIT_LIST_HEAD(&tp->t_items);
> diff --git a/fs/xfs/xfs_trans.h b/fs/xfs/xfs_trans.h
> index 71c2e82e4dad..2b366851e9a4 100644
> --- a/fs/xfs/xfs_trans.h
> +++ b/fs/xfs/xfs_trans.h
> @@ -122,7 +122,6 @@ void	xfs_log_item_init(struct xfs_mount *mp, struct xfs_log_item *item,
>   * This is the structure maintained for every active transaction.
>   */
>  typedef struct xfs_trans {
> -	unsigned int		t_magic;	/* magic number */
>  	unsigned int		t_log_res;	/* amt of log space resvd */
>  	unsigned int		t_log_count;	/* count for perm log res */
>  	unsigned int		t_blk_res;	/* # of blocks resvd */
> -- 
> 2.45.2
> 
> 




[Index of Archives]     [XFS Filesystem Development (older mail)]     [Linux Filesystem Development]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux RAID]     [Linux SCSI]


  Powered by Linux