Re: [PATCH 6/8] xfs_db: enable conversion of rt space units

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



> +	[CT_AGBLOCK] = {
> +		.allowed = M(AGNUMBER)|M(BBOFF)|M(BLKOFF)|M(INOIDX)|M(INOOFF),

Can you space these out with whitespaces around the operators?

> +		.allowed = M(AGBLOCK)|M(AGINO)|M(BBOFF)|M(BLKOFF)|M(INOIDX)|M(INOOFF),

And break up the overly long lines?  In fact I wonder if just having
each M() on it's own line might be even nicer for readability.

> +static inline xfs_rtblock_t
> +xfs_daddr_to_rtb(
> +	struct xfs_mount	*mp,
> +	xfs_daddr_t		daddr)
> +{
> +	return daddr >> mp->m_blkbb_log;
> +}

We already have this in xfs_rtgroup.h in the latest tree, but
I guess that comes later?

>  Set current address to SB header in allocation group
>  .IR agno .
> 
> 
---end quoted text---




[Index of Archives]     [XFS Filesystem Development (older mail)]     [Linux Filesystem Development]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux RAID]     [Linux SCSI]


  Powered by Linux