On Fri, Oct 11, 2024 at 10:05:33AM -0400, Brian Foster wrote: > On Fri, Oct 11, 2024 at 09:54:08AM +0200, Christoph Hellwig wrote: > > On Thu, Oct 10, 2024 at 10:06:15AM -0400, Brian Foster wrote: > > > Seems Ok, but not sure I see the point personally. Rather than a single > > > helper with flags, we have multiple helpers, some of which still mix > > > deltas via an incrementally harder to read boolean param. This seems > > > sort of arbitrary to me. Is this to support some future work? > > > > I just find these multiplexers that have no common logic very confusing. > > > > And yes, I also have some changes to share more logic between the > > delalloc vs non-delalloc block accounting. > > > > I'm not sure what you mean by no common logic. The original > trans_mod_sb() is basically a big switch statement for modifying the > appropriate transaction delta associated with a superblock field. That > seems logical to me. > > Just to be clear, I don't really feel strongly about this one way or the > other. I don't object and I don't think it makes anything worse, and > it's less of a change if half this stuff goes away anyways by changing > how the sb is logged. But I also think sometimes code seems more clear > moreso because we go through the process of refactoring it (i.e. > familiarity bias) over what the code ultimately looks like. > > *shrug* This is all subjective, I'm sure there are other opinions. I'd rather have separate functions for each field, because xfs_trans_mod_sb is a giant dispatch function, with almost no shared logic save the tp->t_flags update at the end. I'm not in love with the 'wasdel' parameter name, but I don't have a better suggestion short of splitting them up into even more tiny functions: void xfs_trans_mod_res_fdblocks(struct xfs_trans *tp, int64_t delta); void xfs_trans_mod_fdblocks(struct xfs_trans *tp, int64_t delta); which is sort of gross since the callers already have a wasdel variable. Reviewed-by: Darrick J. Wong <djwong@xxxxxxxxxx> --D > Brian > >