Hi Carlos, Please pull this branch with changes for xfsprogs for 6.6-rc1. As usual, I did a test-merge with the main upstream branch as of a few minutes ago, and didn't see any conflicts. Please let me know if you encounter any problems. The following changes since commit 94f4f0a7321d52edaa998367cccbe4dd16f1053a: mkfs: fix log sunit rounding when external logs are in use (2024-04-17 14:06:22 -0700) are available in the Git repository at: https://git.kernel.org/pub/scm/linux/kernel/git/djwong/xfsprogs-dev.git tags/fix-realtime-units-6.7_2024-04-17 for you to fetch changes up to 9c69d1c725391f9a65fa8d6d2be337466918e248: xfs_{db,repair}: use m_blockwsize instead of sb_blocksize for rt blocks (2024-04-17 14:06:23 -0700) ---------------------------------------------------------------- xfsprogs: convert utilities to use new rt helpers [03/20] The patches in this series clean up a lot of realtime space usage code the userspace utilities. This involves correcting incorrect type usage, renaming variables to reflect their actual usage; and converting open code logic to use the new helpers that were just added to libxfs. This has been running on the djcloud for months with no problems. Enjoy! Signed-off-by: Darrick J. Wong <djwong@xxxxxxxxxx> ---------------------------------------------------------------- Darrick J. Wong (11): xfs_repair: fix confusing rt space units in the duplicate detection code libxfs: create a helper to compute leftovers of realtime extents libxfs: use helpers to convert rt block numbers to rt extent numbers xfs_repair: convert utility to use new rt extent helpers and types mkfs: convert utility to use new rt extent helpers and types xfs_{db,repair}: convert open-coded xfs_rtword_t pointer accesses to helper xfs_repair: convert helpers for rtbitmap block/wordcount computations xfs_{db,repair}: use accessor functions for bitmap words xfs_{db,repair}: use helpers for rtsummary block/wordcount computations xfs_{db,repair}: use accessor functions for summary info words xfs_{db,repair}: use m_blockwsize instead of sb_blocksize for rt blocks db/check.c | 89 +++++++++++++++++++++++++++++++++++++----------- libxfs/init.c | 8 ++--- libxfs/libxfs_api_defs.h | 8 +++++ libxfs/logitem.c | 3 +- libxfs/trans.c | 3 +- mkfs/proto.c | 41 +++++++++++++++------- repair/agheader.h | 2 +- repair/dinode.c | 21 +++++++----- repair/globals.c | 4 +-- repair/globals.h | 4 +-- repair/incore.c | 16 ++++----- repair/incore.h | 15 ++++---- repair/incore_ext.c | 74 +++++++++++++++++++++------------------- repair/phase4.c | 16 ++++----- repair/phase6.c | 28 +++++++++++---- repair/rt.c | 63 +++++++++++++++++++++++----------- repair/rt.h | 6 ++-- repair/scan.c | 2 +- 18 files changed, 261 insertions(+), 142 deletions(-)