On Wed, Jan 03, 2024 at 03:45:33PM -0800, Darrick J. Wong wrote: > > + __entry->bytes = inode->i_bytes; > > Shouldn't this be (i_blocks << 9) + i_bytes? Actually this should just be doing: __entry->bytes = inode->i_blocks << SECTOR_SHIFT; The bytes name here really confused me. Or we could change the trace point to just report i_block directly and not rename it to bytes and change the unit?