On Mon, Dec 18, 2023 at 02:39:02PM -0800, Darrick J. Wong wrote: > > - trace_xfs_attr_sf_lookup(args); > > - > > ASSERT(ifp->if_format == XFS_DINODE_FMT_LOCAL); > > sfe = &sf->list[0]; > > for (i = 0; i < sf->hdr.count; > > @@ -905,6 +903,9 @@ xfs_attr_shortform_getvalue( > > int i; > > > > ASSERT(args->dp->i_af.if_format == XFS_DINODE_FMT_LOCAL); > > + > > + trace_xfs_attr_sf_lookup(args); > > Shouldn't this get renamed to trace_xfs_attr_shortform_getvalue to match > the function? Especially since xfs_attr_shortform_lookup disappears > later, AFAICT. If we value accurate naming over being able to use a historical trace point: yes. Although in that case I'd probably structure it as a patch adding the new xfs_attr_shortform_getvalue tracepoint only, and removing the xfs_attr_sf_lookup one with the function.