On Wed, Dec 06, 2023 at 10:07:04PM -0800, Christoph Hellwig wrote: > On Wed, Dec 06, 2023 at 06:43:47PM -0800, Darrick J. Wong wrote: > > + if ((VFS_I(sc->ip)->i_mode & 0777) != 0) > > + return false; > > + if (!uid_eq(VFS_I(sc->ip)->i_uid, GLOBAL_ROOT_UID)) > > + return false; > > + if (!gid_eq(VFS_I(sc->ip)->i_gid, GLOBAL_ROOT_GID)) > > + return false; > > Having this in a well-documented helper would be nice to have, > but otherwise this looks good: Ok, I'll split the attr and data fork paths into separate helpers. That'll make them more coherent and cut down on the indenting here. > Reviewed-by: Christoph Hellwig <hch@xxxxxx> Thanks! --D