Hi Chandan, Please pull this branch with changes for xfs for 6.7-rc1. As usual, I did a test-merge with the main upstream branch as of a few minutes ago, and didn't see any conflicts. Please let me know if you encounter any problems. --D The following changes since commit ef5a83b7e597038d1c734ddb4bc00638082c2bf1: xfs: use shifting and masking when converting rt extents, if possible (2023-10-17 16:26:25 -0700) are available in the Git repository at: https://git.kernel.org/pub/scm/linux/kernel/git/djwong/xfs-linux.git tags/refactor-rtbitmap-macros-6.7_2023-10-19 for you to fetch changes up to d0448fe76ac1a9ccbce574577a4c82246d17eec4: xfs: create helpers for rtbitmap block/wordcount computations (2023-10-18 10:58:58 -0700) ---------------------------------------------------------------- xfs: refactor rtbitmap/summary macros [v1.1] In preparation for adding block headers and enforcing endian order in rtbitmap and rtsummary blocks, replace open-coded geometry computations and fugly macros with proper helper functions that can be typechecked. Soon we'll be needing to add more complex logic to the helpers. v1.1: various cleanups suggested by hch With a bit of luck, this should all go splendidly. Signed-off-by: Darrick J. Wong <djwong@xxxxxxxxxx> ---------------------------------------------------------------- Darrick J. Wong (5): xfs: convert the rtbitmap block and bit macros to static inline functions xfs: remove XFS_BLOCKWSIZE and XFS_BLOCKWMASK macros xfs: convert open-coded xfs_rtword_t pointer accesses to helper xfs: convert rt summary macros to helpers xfs: create helpers for rtbitmap block/wordcount computations fs/xfs/libxfs/xfs_format.h | 16 +---- fs/xfs/libxfs/xfs_rtbitmap.c | 142 +++++++++++++++++++++++++---------------- fs/xfs/libxfs/xfs_rtbitmap.h | 100 +++++++++++++++++++++++++++++ fs/xfs/libxfs/xfs_trans_resv.c | 9 +-- fs/xfs/libxfs/xfs_types.h | 2 + fs/xfs/scrub/rtsummary.c | 23 +++---- fs/xfs/xfs_rtalloc.c | 22 +++---- 7 files changed, 218 insertions(+), 96 deletions(-)