> - if (ap->aeof && ap->offset) { > + if (ap->aeof && ap->offset) > error = xfs_bmap_btalloc_at_eof(ap, args, blen, stripe_align); > - } > + > + if (error || args->fsbno != NULLFSBLOCK) > + goto out_perag_rele; Maybe just personal preference, but I find it much easier to read if the error handling is indented and sits in a block with the condition that can cause it, i.e. if (ap->aeof && ap->offset) { error = xfs_bmap_btalloc_at_eof(ap, args, blen, stripe_align); if (error || args->fsbno != NULLFSBLOCK) goto out_perag_rele; } but except for that nipicks this looks good: Reviewed-by: Christoph Hellwig <hch@xxxxxx>