On Mon, Apr 24, 2023 at 11:17:25AM -0700, Darrick J. Wong wrote: > On Sat, Apr 22, 2023 at 04:24:56PM +0800, Zorro Lang wrote: > > On Tue, Apr 11, 2023 at 11:13:52AM -0700, Darrick J. Wong wrote: > > > From: Darrick J. Wong <djwong@xxxxxxxxxx> > > > > > > This test is a long(ish) running stress test, so add it to those groups. > > > > > > Signed-off-by: Darrick J. Wong <djwong@xxxxxxxxxx> > > > --- > > > tests/generic/476 | 2 +- > > > 1 file changed, 1 insertion(+), 1 deletion(-) > > > > > > > > > diff --git a/tests/generic/476 b/tests/generic/476 > > > index 212373d17c..edb0be7b50 100755 > > > --- a/tests/generic/476 > > > +++ b/tests/generic/476 > > > @@ -8,7 +8,7 @@ > > > # bugs in the write path. > > > # > > > . ./common/preamble > > > -_begin_fstest auto rw > > > +_begin_fstest auto rw soak long_rw stress > > > > Sorry for late reviewing. I thought a bit more about this change. I think > > the "soak", "long_rw" and "stress" tags are a bit overlap. If the "stress" > > group means "fsstress", then I think the fsstress test can be in soak > > group too, and currently the test cases in "soak" group are same with the > > "long_rw" group [1]. > > Hm. Given the current definitions of each group: > > long_rw long-soak read write IO path exercisers > rw read/write IO tests > soak long running soak tests of any kind > stress fsstress filesystem exerciser > > I think these all can apply to generic/476 -- it's definitely a > read-write IO test; it's definitely one that does RW for a long time; > and it uses fsstress. > > > So I think we can give the "soak" tag to more test cases with random I/Os > > (fsstress or fsx or others). And rename "long_rw" to "long_soak" for those > > soak group cases which need long soaking time. Then we have two group tags > > for random loading/stress test cases, the testers can (decide to) run these > > random load test cases seperately with more time or loop count. > > I have a counterproposal -- what do you think about redefining 'soak' to > mean "all tests where SOAK_DURATION can be used to control the test > runtime directly"? This shouldn't break anyone's scripts, since the > only members of 'soak' are the ones that get modified by this patchset. Sure, we can check if more cases can use the SOAK_DURATION later, then we add them to soak group. Thanks, Zorro > > --D > > > Anyway, above things can be done in another patchset, I just speak out to > > get more talking:) For this patch: > > > > Reviewed-by: Zorro Lang <zlang@xxxxxxxxxx> > > > > > > > > Thanks, > > Zorro > > > > [1] > > # ./check -n -g soak > > SECTION -- simpledev > > FSTYP -- xfs (non-debug) > > PLATFORM -- Linux/x86_64 > > MKFS_OPTIONS -- -f -m rmapbt=1 /dev/sda3 > > MOUNT_OPTIONS -- -o context=system_u:object_r:root_t:s0 /dev/sda3 /mnt/scratch > > > > generic/521 > > generic/522 > > generic/642 > > > > # ./check -n -g long_rw > > SECTION -- simpledev > > FSTYP -- xfs (non-debug) > > PLATFORM -- Linux/x86_64 > > MKFS_OPTIONS -- -f -m rmapbt=1 /dev/sda3 > > MOUNT_OPTIONS -- -o context=system_u:object_r:root_t:s0 /dev/sda3 /mnt/scratch > > > > generic/521 > > generic/522 > > generic/642 > > > > > > > > > > # Override the default cleanup function. > > > _cleanup() > > > > > >