On Fri, Apr 21, 2023 at 04:24:57PM -0600, Jens Axboe wrote: > On 4/21/23 4:02 PM, Luis Chamberlain wrote: > > On Fri, Apr 21, 2023 at 09:14:00PM +0100, Matthew Wilcox wrote: > >> On Fri, Apr 21, 2023 at 12:58:05PM -0700, Luis Chamberlain wrote: > >>> Just use the PAGE_SECTORS generic define. This produces no functional > >>> changes. While at it use left shift to simplify this even further. > >> > >> How is FOO << 2 simpler than FOO * 4? > >> > >>> - return bioset_init(&iomap_ioend_bioset, 4 * (PAGE_SIZE / SECTOR_SIZE), > >>> + return bioset_init(&iomap_ioend_bioset, PAGE_SECTORS << 2, > > > > We could just do: > > > > > > - return bioset_init(&iomap_ioend_bioset, 4 * (PAGE_SIZE / SECTOR_SIZE), > > + return bioset_init(&iomap_ioend_bioset, 4 * PAGE_SECTORS, > > > > The shift just seemed optimal if we're just going to change it. > > It's going to generate the same code, but the multiplication is arguably > easier to read (or harder to misread). Then let's stick with the 4 * PAGE_SECTORS. Let me know if you need another patch. Luis