[GIT PULL] xfs: new code for 6.3, part 1

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



Hi Linus,

Please pull this branch with changes for xfs for 6.3-rc1.  For this
first pr there's a couple of bug fixes, some cleanups for inconsistent
variable names and reduction of struct boxing and unboxing in the
logging code.  The real fun is coming in a pull request next week, which
will begin reworking allocation group lifetimes and finally replace
confusing indirect calls to the allocator with actual ... function
calls.  I want to let that part experience another week of testing.

As usual, I did a test-merge with the main upstream branch as of a few
minutes ago, and didn't see any conflicts.  Please let me know if you
encounter any problems.

--D

The following changes since commit 6d796c50f84ca79f1722bb131799e5a5710c4700:

Linux 6.2-rc6 (2023-01-29 13:59:43 -0800)

are available in the Git repository at:

git://git.kernel.org/pub/scm/fs/xfs/xfs-linux.git tags/xfs-6.3-merge-2

for you to fetch changes up to dd07bb8b6baf2389caff221f043d9188ce6bab8c:

xfs: revert commit 8954c44ff477 (2023-02-10 09:06:06 -0800)

----------------------------------------------------------------
New code for 6.3-rc1:

* Eliminate repeated boxing and unboxing of log item parameters.
* Clean up some confusing variable names in the log item code.
* Fix a deadlock when doing unwritten extent conversion that causes a
bmbt split when there are sustained memory shortages and the worker
pool runs out of worker threads.
* Fix the panic_mask debug knob not being able to trigger on verifier
errors.
* Constify kobj_type objects.

Signed-off-by: Darrick J. Wong <djwong@xxxxxxxxxx>

----------------------------------------------------------------
Darrick J. Wong (9):
xfs: pass the xfs_bmbt_irec directly through the log intent code
xfs: fix confusing variable names in xfs_bmap_item.c
xfs: pass xfs_extent_free_item directly through the log intent code
xfs: fix confusing xfs_extent_item variable names
xfs: pass rmap space mapping directly through the log intent code
xfs: fix confusing variable names in xfs_rmap_item.c
xfs: pass refcount intent directly through the log intent code
xfs: fix confusing variable names in xfs_refcount_item.c
xfs: revert commit 8954c44ff477

Dave Chinner (1):
xfs: don't use BMBT btree split workers for IO completion

Donald Douwsma (1):
xfs: allow setting full range of panic tags

Thomas Weißschuh (1):
xfs: make kobj_type structures constant

Xu Panda (1):
xfs: use strscpy() to instead of strncpy()

Documentation/admin-guide/xfs.rst |   2 +-
fs/xfs/libxfs/xfs_alloc.c         |  32 ++++-----
fs/xfs/libxfs/xfs_bmap.c          |  32 ++++-----
fs/xfs/libxfs/xfs_bmap.h          |   5 +-
fs/xfs/libxfs/xfs_btree.c         |  18 ++++-
fs/xfs/libxfs/xfs_refcount.c      |  96 ++++++++++++--------------
fs/xfs/libxfs/xfs_refcount.h      |   4 +-
fs/xfs/libxfs/xfs_rmap.c          |  52 +++++++-------
fs/xfs/libxfs/xfs_rmap.h          |   6 +-
fs/xfs/xfs_bmap_item.c            | 137 ++++++++++++++++--------------------
fs/xfs/xfs_error.c                |   2 +-
fs/xfs/xfs_error.h                |  12 +++-
fs/xfs/xfs_extfree_item.c         |  99 +++++++++++++-------------
fs/xfs/xfs_globals.c              |   3 +-
fs/xfs/xfs_refcount_item.c        | 110 ++++++++++++++---------------
fs/xfs/xfs_rmap_item.c            | 142 ++++++++++++++++++--------------------
fs/xfs/xfs_sysfs.c                |  12 ++--
fs/xfs/xfs_sysfs.h                |  10 +--
fs/xfs/xfs_trace.h                |  15 ++--
19 files changed, 377 insertions(+), 412 deletions(-)



[Index of Archives]     [XFS Filesystem Development (older mail)]     [Linux Filesystem Development]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux RAID]     [Linux SCSI]


  Powered by Linux