Am Fr., 23. Dez. 2022 um 16:22 Uhr schrieb Christoph Hellwig <hch@xxxxxxxxxxxxx>: > > +struct folio *iomap_folio_prepare(struct iomap_iter *iter, loff_t pos) > > +{ > > + unsigned fgp = FGP_LOCK | FGP_WRITE | FGP_CREAT | FGP_STABLE | FGP_NOFS; > > + > > + if (iter->flags & IOMAP_NOWAIT) > > + fgp |= FGP_NOWAIT; > > + > > + return __filemap_get_folio(iter->inode->i_mapping, pos >> PAGE_SHIFT, > > + fgp, mapping_gfp_mask(iter->inode->i_mapping)); > > +} > > +EXPORT_SYMBOL(iomap_folio_prepare); > > I'd name this __iomap_get_folio to match __filemap_get_folio. I was looking at it from the filesystem point of view: this helper is meant to be used in ->folio_prepare() handlers, so iomap_folio_prepare() seemed to be a better name than __iomap_get_folio(). > And all iomap exports are EXPORT_SYMBOL_GPL. Sure. Thanks, Andreas