On 5/17/22 4:20 AM, Jan Kara wrote: > On Mon 16-05-22 09:47:09, Stefan Roesch wrote: >> This splits off the functions need_file_update_time() and >> do_file_update_time() from the function file_update_time(). >> >> This is required to support async buffered writes. >> No intended functional changes in this patch. >> >> Signed-off-by: Stefan Roesch <shr@xxxxxx> > > ... >> +int file_update_time(struct file *file) >> +{ >> + int err; >> + struct inode *inode = file_inode(file); >> + struct timespec64 now = current_time(inode); >> + >> + err = need_file_update_time(inode, file, &now); >> + if (err < 0) >> + return err; >> + >> + return do_file_update_time(inode, file, &now, err); >> +} >> EXPORT_SYMBOL(file_update_time); > > I guess 'ret' would be a more appropriate variable name than 'err'. > Otherwise the patch looks good. > I renamed it to ret in the next version of the patch series. > Honza