On Wed, Mar 09, 2022 at 11:22:17AM -0800, Darrick J. Wong wrote: > + if ((mask & ATTR_UID) && XFS_IS_UQUOTA_ON(mp) && > + !uid_eq(inode->i_uid, iattr->ia_uid)) { Nit: I think in this case an indentation like: if ((mask & ATTR_UID) && XFS_IS_UQUOTA_ON(mp) && !uid_eq(inode->i_uid, iattr->ia_uid)) { is way more readable. Same for the gid case. Otherwise this looks like a nice cleanup: Reviewed-by: Christoph Hellwig <hch@xxxxxx>