On 2/27/22 13:57, Jens Axboe wrote:
...
+ return res;
+ return (res == n ? len : res * PAGE_SIZE) - *start;
Trying to be clever like that just makes the code a lot less readable. I
should not have to reason about a return value. Same in the other
function.
No argument there. This was shamelessly lifted from
iov_iter_get_pages(), and I initially calculated that keeping it
identical to that known-good code, where possible, was better than
fixing it up.
However, I'll go ahead and simplify it--with pleasure--based on this
feedback.
thanks,
--
John Hubbard
NVIDIA