On 8/2/21 4:50 PM, Pavel Reichl wrote:
Hi, Eric recently suggested that removing prefix 'platform_' from function names in xfsprogs could be a good idea.
So, that wasn't *quite* what I had in mind. I'm less worried about function names, and more interested in getting rid of indirections that have become pointless after we removed the other "platforms" (irix, bsd, osx) For example: char * platform_findrawpath(char *path) { return path; } char * platform_findblockpath(char *path) { return path; } int platform_direct_blockdev(void) { return 1; } Those did something more interesting or complex under some other OS, but for the code today, they're just pointless and confusing. So my suggestion is to remove them (and anything similarly pointless) to make the code less confusing. Later on if we want to remove the "platform_" namespace altogether that might be fine but for now, let's just remove the silly stuff like shown above. Thanks, -Eric