Over time, we've moved from using bp->b_bn as the physical disk address for a buffer to using the address of the first buffer map attached to the buffer. This can be seen by the implementation of XFS_BUF_ADDR() macro: #define XFS_BUF_ADDR(bp) ((bp)->b_maps[0].bm_bn) The bp->b_bn value is now used as the buffer cache index for the buffer, and it is always set to XFS_BUF_DADDR_NULL for uncached buffers. Hence code that uses bp->b_bn for the physical address of the buffer will not do the right thing when passed an uncached buffer. THis series of patches addresses this problem. It adds a helper function xfs_buf_daddr() to extract the physical address of the buffer from it, and replaces all the open coded bp->b_bn accesses and the XFS_BUF_ADDR() users to use it. It then renames b_bn to b_index and converts all the internal cache lookup code to use b_index rather than b_bn. The result is that all code now uses xfs_buf_daddr() where physical addresses are required, and the cache index variable isn't named in a manner that engenders external use of access. The changes end up being relatively small, and the impact on userspace outside libxfs is even smaller (only a couple of dozen references to b_bn or XFS_BUF_ADDR). Version 2 - rebase on 5.14-rc4 + for-next + "xfs: rework feature flags v3" - use __be64 type for comparison in xfs_btree_new_iroot() - rename b_index to b_rhash_key - fix typos and wording in commit messages Version 1 - based on 5.14-rc4 + for-next - https://lore.kernel.org/linux-xfs/20210810052851.42312-1-david@xxxxxxxxxxxxx/