Re: [PATCH 02/16] xfs: rename xfs_has_attr()

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Jul 14, 2021 at 02:18:58PM +1000, Dave Chinner wrote:
> From: Dave Chinner <dchinner@xxxxxxxxxx>
> 
> xfs_has_attr() is poorly named. It has global scope as it is defined
> in a header file, but it has no namespace scope that tells us what
> it is checking has attributes. It's not even clear what "has_attr"
> means, because what it is actually doing is an attribute fork lookup
> to see if the attribute exists.
> 
> Upcoming patches use this "xfs_has_<foo>" namespace for global
> filesystem features, which conflicts with this function.
> 
> Rename xfs_has_attr() to xfs_attr_lookup() and make it a static
> function, freeing up the "xfs_has_" namespace for global scope
> usage.
> 
> Signed-off-by: Dave Chinner <dchinner@xxxxxxxxxx>

LGTM, though Allison is probably the expert here ;)
Reviewed-by: Darrick J. Wong <djwong@xxxxxxxxxx>

--D

> ---
>  fs/xfs/libxfs/xfs_attr.c | 8 ++++----
>  fs/xfs/libxfs/xfs_attr.h | 1 -
>  2 files changed, 4 insertions(+), 5 deletions(-)
> 
> diff --git a/fs/xfs/libxfs/xfs_attr.c b/fs/xfs/libxfs/xfs_attr.c
> index d9d7d5137b73..d31ea7f1a7fc 100644
> --- a/fs/xfs/libxfs/xfs_attr.c
> +++ b/fs/xfs/libxfs/xfs_attr.c
> @@ -623,8 +623,8 @@ xfs_attr_set_iter(
>  /*
>   * Return EEXIST if attr is found, or ENOATTR if not
>   */
> -int
> -xfs_has_attr(
> +static int
> +xfs_attr_lookup(
>  	struct xfs_da_args	*args)
>  {
>  	struct xfs_inode	*dp = args->dp;
> @@ -762,7 +762,7 @@ xfs_attr_set(
>  	}
>  
>  	if (args->value) {
> -		error = xfs_has_attr(args);
> +		error = xfs_attr_lookup(args);
>  		if (error == -EEXIST && (args->attr_flags & XATTR_CREATE))
>  			goto out_trans_cancel;
>  		if (error == -ENOATTR && (args->attr_flags & XATTR_REPLACE))
> @@ -777,7 +777,7 @@ xfs_attr_set(
>  		if (!args->trans)
>  			goto out_unlock;
>  	} else {
> -		error = xfs_has_attr(args);
> +		error = xfs_attr_lookup(args);
>  		if (error != -EEXIST)
>  			goto out_trans_cancel;
>  
> diff --git a/fs/xfs/libxfs/xfs_attr.h b/fs/xfs/libxfs/xfs_attr.h
> index 8de5d1d2733e..5e71f719bdd5 100644
> --- a/fs/xfs/libxfs/xfs_attr.h
> +++ b/fs/xfs/libxfs/xfs_attr.h
> @@ -490,7 +490,6 @@ int xfs_attr_get_ilocked(struct xfs_da_args *args);
>  int xfs_attr_get(struct xfs_da_args *args);
>  int xfs_attr_set(struct xfs_da_args *args);
>  int xfs_attr_set_args(struct xfs_da_args *args);
> -int xfs_has_attr(struct xfs_da_args *args);
>  int xfs_attr_remove_args(struct xfs_da_args *args);
>  int xfs_attr_remove_iter(struct xfs_delattr_context *dac);
>  bool xfs_attr_namecheck(const void *name, size_t length);
> -- 
> 2.31.1
> 



[Index of Archives]     [XFS Filesystem Development (older mail)]     [Linux Filesystem Development]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux RAID]     [Linux SCSI]


  Powered by Linux