Re: [PATCH 3/3] common/populate: change how we describe cached populated images

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Mon, Mar 22, 2021 at 09:19:59PM -0700, Darrick J. Wong wrote:
> From: Darrick J. Wong <djwong@xxxxxxxxxx>
> 
> The device name of a secondary storage device isn't all that important,
> but the size is.
> 
> Signed-off-by: Darrick J. Wong <djwong@xxxxxxxxxx>
> ---
>  common/populate |   14 ++++++++++++--
>  1 file changed, 12 insertions(+), 2 deletions(-)
> 
> 
> diff --git a/common/populate b/common/populate
> index c01b7e0e..94bf5ce9 100644
> --- a/common/populate
> +++ b/common/populate
> @@ -808,13 +808,23 @@ _fill_fs()
>  _scratch_populate_cache_tag() {
>  	local extra_descr=""
>  	local size="$(blockdev --getsz "${SCRATCH_DEV}")"
> +	local logdev="none"
> +	local rtdev="none"
> +
> +	if [ "${USE_EXTERNAL}" = "yes" ] && [ -n "${SCRATCH_LOGDEV}" ]; then
> +		logdev="$(blockdev --getsz "${SCRATCH_LOGDEV}")"
> +	fi
> +
> +	if [ "${USE_EXTERNAL}" = "yes" ] && [ -n "${SCRATCH_RTDEV}" ]; then
> +		rtdev="$(blockdev --getsz "${SCRATCH_RTDEV}")"

Shouldn't these variables be called LOGDEV_SIZE and RTDEV_SIZE?



[Index of Archives]     [XFS Filesystem Development (older mail)]     [Linux Filesystem Development]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux RAID]     [Linux SCSI]


  Powered by Linux