Hi all, This series tweaks the xfs_log_quiesce() codepath to lift out the explicit buffer target LRU draining and isolate it to the unmount path. It's unnecessary to reclaim all buffers on filesystem freeze or read-only remount, and this also causes such operations to stall if a read heavy workload is running in parallel. Patch 1 is a simple rename and patch 2 implements the functional change. Thoughts, reviews, flames appreciated. Brian Brian Foster (2): xfs: rename xfs_wait_buftarg() to xfs_buftarg_drain() xfs: don't drain buffer lru on freeze and read-only remount fs/xfs/xfs_buf.c | 30 ++++++++++++++++++++---------- fs/xfs/xfs_buf.h | 11 ++++++----- fs/xfs/xfs_log.c | 8 +++++--- fs/xfs/xfs_mount.c | 4 ++-- fs/xfs/xfs_trace.h | 2 +- 5 files changed, 34 insertions(+), 21 deletions(-) -- 2.26.2