On Thu, Oct 15, 2020 at 09:54:39AM +0200, Christoph Hellwig wrote: > I don't really like the xfs_inode_alloc_blocksize helper, given that > it is very easy to be confused with the allocsize concept. > > I'd just add a helper ala: > > static bool > xfs_falloc_is_unaligned( > struct inode *inode, > loff_t offset, > loff_t len) > { > struct xfs_mount *mp = XFS_I(ip)->i_mount; > > unsigned int blksize_mask = i_blocksize(inode) - 1; > > if (XFS_IS_REALTIME_INODE(XFS_I(ip))) > blksize_mask = XFS_FSB_TO_B(mp, mp->m_sb.sb_rextsize) - 1; UGH the thing that I just noticed (and fstests doesn't seem to cover given the number of them that sort of blew up) is the fact that the rt extent size only has to be some multiple of the fs blocksize, not the power-of-2 multiple that I mistakenly assumed. Soooo none of this masking stuff actually works properly and I'm going to drop this patch until I figure out how to do this properly, with a bunch of fugly division and whatnot... I guess the silver lining is that rtextsize can't be larger than 1G so at least I can probably use simple division and not the div64 mess. Self NAK. --D > > return (offset & blksize_mask) || (len & blksize_mask); > }