Hi folks, It's Friday, so of course the for-next branch of the xfsprogs repository at: git://git.kernel.org/pub/scm/fs/xfs/xfsprogs-dev.git has just been updated and tagged with v5.9.0-rc0 This is just the libxfs/ sync bits. Now onto the real content. The new head of the for-next branch is commit: 06267c3e (HEAD -> guilt/libxfs-5.9-sync, tag: v5.9.0-rc0, korg/libxfs-5.9-sync, korg/for-next, refs/patches/libxfs-5.9-sync/5.9.0-rc0) xfsprogs: Release v5.9.0-rc0 New Commits: Allison Collins (22): [11b4b23d] xfs: Add xfs_has_attr and subroutines [36b8f99d] xfs: Check for -ENOATTR or -EEXIST [91986fc1] xfs: Factor out new helper functions xfs_attr_rmtval_set [7efadb7a] xfs: Pull up trans handling in xfs_attr3_leaf_flipflags [e37811b3] xfs: Split apart xfs_attr_leaf_addname [32221b28] xfs: Refactor xfs_attr_try_sf_addname [4345a0a1] xfs: Pull up trans roll from xfs_attr3_leaf_setflag [5a2edbba] xfs: Factor out xfs_attr_rmtval_invalidate [e936ed7a] xfs: Pull up trans roll in xfs_attr3_leaf_clearflag [978b6ada] xfs: Refactor xfs_attr_rmtval_remove [0a98254e] xfs: Pull up xfs_attr_rmtval_invalidate [e6133b6f] xfs: Add helper function xfs_attr_node_shrink [ebdc3357] xfs: Remove unneeded xfs_trans_roll_inode calls [9086487f] xfs: Remove xfs_trans_roll in xfs_attr_node_removename [fb68bf93] xfs: Add helpers xfs_attr_is_shortform and xfs_attr_set_shortform [1a27e045] xfs: Add helper function xfs_attr_leaf_mark_incomplete [0a194afd] xfs: Add remote block helper functions [05c54abe] xfs: Add helper function xfs_attr_node_removename_setup [acefd66b] xfs: Add helper function xfs_attr_node_removename_rmt [aff8f72d] xfs: Simplify xfs_attr_leaf_addname [1df775fa] xfs: Simplify xfs_attr_node_addname [484c2bf6] xfs: Lift -ENOSPC handler from xfs_attr_leaf_addname Brian Foster (3): [8f67a46c] xfs: preserve rmapbt swapext block reservation from freed blocks [625c12fb] xfs: fix inode allocation block res calculation precedence [d6e8deb1] xfs: fix off-by-one in inode alloc block reservation calculation Carlos Maiolino (3): [d7faa18a] xfs: Remove kmem_zone_alloc() usage [17e074de] xfs: Remove kmem_zone_zalloc() usage [2db3075b] xfs: Refactor xfs_da_state_alloc() helper Darrick J. Wong (13): [f8b581d6] libxfs: actually make buffers track the per-ag structures [23571db9] xfs: rename xfs_bmap_is_real_extent to is_written_extent [9ff3a1a7] xfs: redesign the reflink remap loop to fix blkres depletion crash [a579493d] xfs: rename dquot incore state flags [8330c89c] xfs: make XFS_DQUOT_CLUSTER_SIZE_FSB part of the ondisk format [12907581] xfs: remove qcore from incore dquots [bce109af] xfs: drop the type parameter from xfs_dquot_verify [8e4128a7] xfs: rename XFS_DQ_{USER,GROUP,PROJ} to XFS_DQTYPE_* [4a4b0690] xfs: create xfs_dqtype_t to represent quota types [28518f77] xfs: improve ondisk dquot flags checking [cde0e6a6] xfs: rename the ondisk dquot d_flags to d_type [b28d8768] xfs: initialize the shortform attr header padding entry [d1f29689] xfs: fix xfs_bmap_validate_extent_raw when checking attr fork of rt files Dave Chinner (5): [d5c6e6a1] xfs: Don't allow logging of XFS_ISTALE inodes [847ab4e0] xfs: add an inode item lock [2b8ea826] xfs: pin inode backing buffer to the inode log item [2efa10f3] xfs: attach inodes to the cluster buffer when dirtied [1da5326f] xfs: remove xfs_inobp_check() Eric Sandeen (2): [be2f3d39] xfs: fix boundary test in xfs_attr_shortform_verify [06267c3e] xfsprogs: Release v5.9.0-rc0 Gao Xiang (1): [10c0a390] xfs: get rid of unnecessary xfs_perag_{get,put} pairs Jan Kara (1): [cdef05dd] writeback: Drop I_DIRTY_TIME_EXPIRE Keyur Patel (1): [c2f0ae02] xfs: Couple of typo fixes in comments Randy Dunlap (2): [98c76f9e] xfs: xfs_btree_staging.h: delete duplicated words [809c2c46] xfs: delete duplicated words + other fixes Code Diffstat: VERSION | 4 +- configure.ac | 2 +- db/check.c | 21 +- db/dquot.c | 2 +- debian/changelog | 6 + doc/CHANGES | 4 + include/kmem.h | 12 +- include/xfs_trans.h | 2 + libxfs/kmem.c | 8 +- libxfs/libxfs_io.h | 9 +- libxfs/libxfs_priv.h | 5 + libxfs/logitem.c | 4 +- libxfs/rdwr.c | 20 +- libxfs/trans.c | 34 +- libxfs/util.c | 1 + libxfs/xfs_ag.c | 4 +- libxfs/xfs_ag_resv.h | 12 - libxfs/xfs_alloc.c | 25 +- libxfs/xfs_alloc_btree.c | 10 +- libxfs/xfs_attr.c | 865 +++++++++++++++++++++++++++----------------- libxfs/xfs_attr.h | 1 + libxfs/xfs_attr_leaf.c | 125 ++++--- libxfs/xfs_attr_leaf.h | 3 + libxfs/xfs_attr_remote.c | 216 +++++++---- libxfs/xfs_attr_remote.h | 3 +- libxfs/xfs_bmap.c | 10 +- libxfs/xfs_bmap.h | 15 +- libxfs/xfs_bmap_btree.c | 2 +- libxfs/xfs_btree_staging.h | 6 +- libxfs/xfs_da_btree.c | 12 +- libxfs/xfs_da_btree.h | 2 +- libxfs/xfs_dir2_node.c | 17 +- libxfs/xfs_dquot_buf.c | 25 +- libxfs/xfs_format.h | 36 +- libxfs/xfs_ialloc.c | 32 +- libxfs/xfs_ialloc_btree.c | 2 +- libxfs/xfs_inode_buf.c | 33 +- libxfs/xfs_inode_buf.h | 6 - libxfs/xfs_inode_fork.c | 6 +- libxfs/xfs_quota_defs.h | 31 +- libxfs/xfs_refcount_btree.c | 6 +- libxfs/xfs_rmap_btree.c | 11 +- libxfs/xfs_rtbitmap.c | 2 +- libxfs/xfs_sb.c | 2 +- libxfs/xfs_shared.h | 1 + libxfs/xfs_trans_inode.c | 114 ++++-- libxfs/xfs_trans_space.h | 4 +- logprint/log_misc.c | 4 +- repair/dinode.c | 12 +- repair/phase7.c | 6 +- repair/quotacheck.c | 42 +-- repair/quotacheck.h | 2 +- 52 files changed, 1099 insertions(+), 740 deletions(-)
Attachment:
OpenPGP_0x20AE1692E13DDEE0.asc
Description: application/pgp-keys
Attachment:
OpenPGP_signature
Description: OpenPGP digital signature