Hi all, This series prepares the incore inode walking code used by the eofblocks/cowblocks scanner to handle deferred inode inactivation. First we clean up the eofblocks/cowblocks incore inode walking code to get rid of some of the warts left by reflink development. Next, we rip out the many trivial wrapper functions that don't add much value. Finally, we refactor the various helpers and predicate functions to reduce open-coded logic. For v4 we get rid of the "ici" prefixes and merely straighten out the inode walk function names to "xfs_inode_walk*". If you're going to start using this mess, you probably ought to just pull from my git trees, which are linked below. This is an extraordinary way to destroy everything. Enjoy! Comments and questions are, as always, welcome. --D kernel git tree: https://git.kernel.org/cgit/linux/kernel/git/djwong/xfs-linux.git/log/?h=incore-inode-walk --- fs/xfs/xfs_icache.c | 283 +++++++++++++++++++++------------------------- fs/xfs/xfs_icache.h | 51 +------- fs/xfs/xfs_ioctl.c | 35 ++++++ fs/xfs/xfs_qm_syscalls.c | 17 +-- 4 files changed, 176 insertions(+), 210 deletions(-)