Hi, Am Do., 30. Apr. 2020 um 23:56 Uhr schrieb Guoqing Jiang <guoqing.jiang@xxxxxxxxxxxxxxx>: > The logic in attach_page_buffers and __clear_page_buffers are quite > paired, but > > 1. they are located in different files. > > 2. attach_page_buffers is implemented in buffer_head.h, so it could be > used by other files. But __clear_page_buffers is static function in > buffer.c and other potential users can't call the function, md-bitmap > even copied the function. > > So, introduce the new attach/clear_page_private to replace them. With > the new pair of function, we will remove the usage of attach_page_buffers > and __clear_page_buffers in next patches. Thanks for the new names from > Christoph Hellwig. > > Suggested-by: Matthew Wilcox <willy@xxxxxxxxxxxxx> > Cc: Andrew Morton <akpm@xxxxxxxxxxxxxxxxxxxx> > Cc: "Darrick J. Wong" <darrick.wong@xxxxxxxxxx> > Cc: William Kucharski <william.kucharski@xxxxxxxxxx> > Cc: "Kirill A. Shutemov" <kirill.shutemov@xxxxxxxxxxxxxxx> > Cc: Andreas Gruenbacher <agruenba@xxxxxxxxxx> > Cc: Yang Shi <yang.shi@xxxxxxxxxxxxxxxxx> > Cc: Yafang Shao <laoar.shao@xxxxxxxxx> > Cc: Song Liu <song@xxxxxxxxxx> > Cc: linux-raid@xxxxxxxxxxxxxxx > Cc: Chris Mason <clm@xxxxxx> > Cc: Josef Bacik <josef@xxxxxxxxxxxxxx> > Cc: David Sterba <dsterba@xxxxxxxx> > Cc: linux-btrfs@xxxxxxxxxxxxxxx > Cc: Alexander Viro <viro@xxxxxxxxxxxxxxxxxx> > Cc: Jaegeuk Kim <jaegeuk@xxxxxxxxxx> > Cc: Chao Yu <chao@xxxxxxxxxx> > Cc: linux-f2fs-devel@xxxxxxxxxxxxxxxxxxxxx > Cc: Christoph Hellwig <hch@xxxxxxxxxxxxx> > Cc: linux-xfs@xxxxxxxxxxxxxxx > Cc: Anton Altaparmakov <anton@xxxxxxxxxx> > Cc: linux-ntfs-dev@xxxxxxxxxxxxxxxxxxxxx > Cc: Mike Marshall <hubcap@xxxxxxxxxxxx> > Cc: Martin Brandenburg <martin@xxxxxxxxxxxx> > Cc: devel@xxxxxxxxxxxxxxxxxx > Cc: Thomas Gleixner <tglx@xxxxxxxxxxxxx> > Cc: Sebastian Andrzej Siewior <bigeasy@xxxxxxxxxxxxx> > Cc: Roman Gushchin <guro@xxxxxx> > Cc: Andreas Dilger <adilger@xxxxxxxxx> > Signed-off-by: Guoqing Jiang <guoqing.jiang@xxxxxxxxxxxxxxx> > --- > RFC -> RFC V2: Address the comments from Christoph Hellwig > 1. change function names to attach/clear_page_private and add comments. > 2. change the return type of attach_page_private. > > include/linux/pagemap.h | 35 +++++++++++++++++++++++++++++++++++ > 1 file changed, 35 insertions(+) > > diff --git a/include/linux/pagemap.h b/include/linux/pagemap.h > index a8f7bd8ea1c6..2e515f210b18 100644 > --- a/include/linux/pagemap.h > +++ b/include/linux/pagemap.h > @@ -205,6 +205,41 @@ static inline int page_cache_add_speculative(struct page *page, int count) > return __page_cache_add_speculative(page, count); > } > > +/** > + * attach_page_private - attach data to page's private field and set PG_private. > + * @page: page to be attached and set flag. > + * @data: data to attach to page's private field. > + * > + * Need to take reference as mm.h said "Setting PG_private should also increment > + * the refcount". > + */ > +static inline void attach_page_private(struct page *page, void *data) > +{ > + get_page(page); > + set_page_private(page, (unsigned long)data); > + SetPagePrivate(page); > +} > + > +/** > + * clear_page_private - clear page's private field and PG_private. > + * @page: page to be cleared. > + * > + * The counterpart function of attach_page_private. > + * Return: private data of page or NULL if page doesn't have private data. > + */ > +static inline void *clear_page_private(struct page *page) > +{ > + void *data = (void *)page_private(page); > + > + if (!PagePrivate(page)) > + return NULL; > + ClearPagePrivate(page); > + set_page_private(page, 0); > + put_page(page); > + > + return data; > +} > + I like this in general, but the name clear_page_private suggests that this might be the inverse operation of set_page_private, which it is not. So maybe this can be renamed to detach_page_private to more clearly indicate that it pairs with attach_page_private? > #ifdef CONFIG_NUMA > extern struct page *__page_cache_alloc(gfp_t gfp); > #else > -- > 2.17.1 > Thanks, Andreas