On Mon, Apr 27, 2020 at 03:52:29PM +0200, Christoph Hellwig wrote: > This list contains pretty much everything that is not a buffer. The > comment calls it item_list, which is a much better name than inode > list, so switch the actual variable name to that as well. > > Signed-off-by: Christoph Hellwig <hch@xxxxxx> > --- Reviewed-by: Brian Foster <bfoster@xxxxxxxxxx> > fs/xfs/xfs_log_recover.c | 8 ++++---- > 1 file changed, 4 insertions(+), 4 deletions(-) > > diff --git a/fs/xfs/xfs_log_recover.c b/fs/xfs/xfs_log_recover.c > index 750a81b941ea4..33cac61570abe 100644 > --- a/fs/xfs/xfs_log_recover.c > +++ b/fs/xfs/xfs_log_recover.c > @@ -1847,7 +1847,7 @@ xlog_recover_reorder_trans( > LIST_HEAD(cancel_list); > LIST_HEAD(buffer_list); > LIST_HEAD(inode_buffer_list); > - LIST_HEAD(inode_list); > + LIST_HEAD(item_list); > > list_splice_init(&trans->r_itemq, &sort_list); > list_for_each_entry_safe(item, n, &sort_list, ri_list) { > @@ -1883,7 +1883,7 @@ xlog_recover_reorder_trans( > case XFS_LI_BUD: > trace_xfs_log_recover_item_reorder_tail(log, > trans, item, pass); > - list_move_tail(&item->ri_list, &inode_list); > + list_move_tail(&item->ri_list, &item_list); > break; > default: > xfs_warn(log->l_mp, > @@ -1904,8 +1904,8 @@ xlog_recover_reorder_trans( > ASSERT(list_empty(&sort_list)); > if (!list_empty(&buffer_list)) > list_splice(&buffer_list, &trans->r_itemq); > - if (!list_empty(&inode_list)) > - list_splice_tail(&inode_list, &trans->r_itemq); > + if (!list_empty(&item_list)) > + list_splice_tail(&item_list, &trans->r_itemq); > if (!list_empty(&inode_buffer_list)) > list_splice_tail(&inode_buffer_list, &trans->r_itemq); > if (!list_empty(&cancel_list)) > -- > 2.26.1 >