On Wed, Feb 19, 2020 at 09:52:34AM -0500, Brian Foster wrote: > FWIW, I don't really view this patch as a straightforward > simplification. IMO, this slightly sacrifices readability for slightly > less code and a smaller xfs_icdinode. That might be acceptable... I I actually find it easier to read. The per-inode versioning seems to suggest inodes could actually be different on the same fs, while the new one makes it clear that all inodes on the fs are the same. > don't feel terribly strongly against it, but to me the explicit version > checks are more clear in cases where the _hascrc() check is not used for > something that is obviously CRC related (which is a pattern I'm > generally not a fan of). xfs_sb_version_hascrc is rather misnamed unfortunately. In fact I think just open coding it as 'XFS_SB_VERSION_NUM(sbp) == XFS_SB_VERSION_5' would improve things quite a bit.