On Tue, Feb 18, 2020 at 10:06:08AM +1100, Dave Chinner wrote: > > lock_mode = xfs_ilock_attr_map_shared(args->dp); > > - error = xfs_attr_get_ilocked(args->dp, args); > > + error = xfs_attr_get_ilocked(args); > > xfs_iunlock(args->dp, lock_mode); > > ... at this point I really would like to see the "args->dp" pointer > get renamed. "dp" was originally short for "directory inode > pointer", but it's clear that it hasn't meant that for a long time. > It's just an inode pointer. > > That's out of scope for this patch set, though, so maybe the next > cleanup patchset? That's for another time. And while I found the dp naming rather odd I'm not sure it really is worth the churn on its own. That being said the da_args structure really needs to be split into dir and attr args, as those can be almost entirely separate anyway.