Re: [PATCH 19/29] xfs: replace ATTR_ENTBASESIZE with offsetoff

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, Jan 21, 2020 at 10:36:21AM -0800, Darrick J. Wong wrote:
> > -	((ATTR_ENTBASESIZE + (namelen) + 1 + sizeof(uint32_t)-1) \
> > +	((offsetof(struct attrlist_ent, a_name) + \
> > +	 (namelen) + 1 + sizeof(uint32_t) - 1) \
> >  	 & ~(sizeof(uint32_t)-1))
> 
> This looks like an open-coded round_up(), doesn't it?  Or roundup(), I
> can't remember which is which. :?

It looks ok this way, but I'll see if there is something more fancy to
use here..



[Index of Archives]     [XFS Filesystem Development (older mail)]     [Linux Filesystem Development]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux RAID]     [Linux SCSI]


  Powered by Linux