> - xfs_dablk_t blkno, > - int blkcnt) > + xfs_dablk_t tblkno, > + int tblkcnt) Nit: I would keep the names without the t, presuming it means temporary. In fact the hunks touching this function seems to be unrelated to the rest of the patch. > + struct xfs_mount *mp = bp->b_mount; > + struct xfs_attr_leafblock *leaf; > struct xfs_attr_leaf_entry *entry; > struct xfs_attr_leaf_name_remote *name_rmt; > - struct xfs_attr_inactive_list *list; > - struct xfs_attr_inactive_list *lp; > int error; > - int count; > - int size; > - int tmp; > int i; > - struct xfs_mount *mp = bp->b_mount; > > leaf = bp->b_addr; Maybe move this to the declaration line when you touch that area anyway? > entry = xfs_attr3_leaf_entryp(leaf); > for (i = 0; i < ichdr.count; entry++, i++) { > + int blkcnt; > > + if (!be16_to_cpu(entry->nameidx) || While we touch this: the be16_to_cpu is superflous, given that the value is used in boolean context. Otherwise this looks good to me.