Re: [PATCH 3/3] fsr: remove shadow variable in fsr_setup_attr_fork

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Wed, Dec 18, 2019 at 04:56:20PM -0600, Eric Sandeen wrote:
> From: Eric Sandeen <sandeen@xxxxxxxxxx>
> 
> There's no need for the extra inner-scope ret variable in this
> function, so remove it.  The shadow was harmless though.
> 
> Fixes: f31b5e12 ("libfrog: refactor open-coded bulkstat calls")
> Signed-off-by: Eric Sandeen <sandeen@xxxxxxxxxx>

Looks ok,
Reviewed-by: Darrick J. Wong <darrick.wong@xxxxxxxxxx>

--D

> ---
> 
> diff --git a/fsr/xfs_fsr.c b/fsr/xfs_fsr.c
> index 77a10a1d..32282126 100644
> --- a/fsr/xfs_fsr.c
> +++ b/fsr/xfs_fsr.c
> @@ -988,7 +988,6 @@ fsr_setup_attr_fork(
>  	do {
>  		struct xfs_bulkstat	tbstat;
>  		char		name[64];
> -		int		ret;
>  
>  		/*
>  		 * bulkstat the temp inode to see what the forkoff is.  Use
> 



[Index of Archives]     [XFS Filesystem Development (older mail)]     [Linux Filesystem Development]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux RAID]     [Linux SCSI]


  Powered by Linux