Re: [PATCH v3] fsstress: add renameat2 support

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Thu, Oct 17, 2019 at 09:47:19AM +0800, kaixuxia wrote:
> Support the renameat2 syscall in fsstress.
> 
> Signed-off-by: kaixuxia <kaixuxia@xxxxxxxxxxx>
> ---
> Changes in v3:
>  - Fix the rename(..., 0) case, avoide to cripple fsstress.
> 
>  ltp/fsstress.c | 158 +++++++++++++++++++++++++++++++++++++++++++++------------
>  1 file changed, 125 insertions(+), 33 deletions(-)
> 
> diff --git a/ltp/fsstress.c b/ltp/fsstress.c
> index 51976f5..1a20358 100644
> --- a/ltp/fsstress.c
> +++ b/ltp/fsstress.c
...
> @@ -1528,14 +1569,17 @@ rename_path(pathname_t *name1, pathname_t *name2)
>  	pathname_t	newname2;
>  	int		rval;
>  
> -	rval = rename(name1->path, name2->path);
> +	if (mode == 0)
> +		rval = rename(name1->path, name2->path);
> +	else
> +		rval = renameat2(AT_FDCWD, name1->path, AT_FDCWD, name2->path, mode);

This adds a long line (> 80 characters) here and in several more places
below. I know there are other instances of this in the file, but we
probably shouldn't add new ones.

>  	if (rval >= 0 || errno != ENAMETOOLONG)
>  		return rval;
>  	separate_pathname(name1, buf1, &newname1);
>  	separate_pathname(name2, buf2, &newname2);
>  	if (strcmp(buf1, buf2) == 0) {
>  		if (chdir(buf1) == 0) {
> -			rval = rename_path(&newname1, &newname2);
> +			rval = rename_path(&newname1, &newname2, mode);
>  			assert(chdir("..") == 0);
>  		}
>  	} else {
...
> @@ -4234,35 +4288,49 @@ rename_f(int opno, long r)
>  	init_pathname(&f);
>  	if (!get_fname(FT_ANYm, r, &f, &flp, &fep, &v1)) {
>  		if (v1)
> -			printf("%d/%d: rename - no filename\n", procid, opno);
> +			printf("%d/%d: rename - no source filename\n", procid, opno);
>  		free_pathname(&f);
>  		return;
>  	}
> -
> -	/* get an existing directory for the destination parent directory name */
> -	if (!get_fname(FT_DIRm, random(), NULL, NULL, &dfep, &v))
> -		parid = -1;
> -	else
> -		parid = dfep->id;
> -	v |= v1;
> -
> -	/* generate a new path using an existing parent directory in name */
> -	init_pathname(&newf);
> -	e = generate_fname(dfep, flp - flist, &newf, &id, &v1);
> -	v |= v1;
> -	if (!e) {
> -		if (v) {
> -			(void)fent_to_name(&f, &flist[FT_DIR], dfep);
> -			printf("%d/%d: rename - no filename from %s\n",
> -				procid, opno, f.path);
> +	/* Both pathnames must exist for the RENAME_EXCHANGE */
> +	if (mode == RENAME_EXCHANGE) {
> +		init_pathname(&newf);
> +		if (!get_fname(FT_ANYm, random(), &newf, NULL, &dfep, &v1)) {
> +			if (v1)
> +				printf("%d/%d: rename - no target filename\n", procid, opno);
> +			free_pathname(&newf);
> +			free_pathname(&f);
> +			return;
> +		}

Need a v |= v1 here.

> +		id = dfep->id;
> +		parid = dfep->parent;
> +	} else {
> +		/* get an existing directory for the destination parent directory name */
> +		if (!get_fname(FT_DIRm, random(), NULL, NULL, &dfep, &v))
> +			parid = -1;
> +		else
> +			parid = dfep->id;
> +		v |= v1;
> +
> +		/* generate a new path using an existing parent directory in name */
> +		init_pathname(&newf);
> +		e = generate_fname(dfep, flp - flist, &newf, &id, &v1);
> +		v |= v1;
> +		if (!e) {
> +			if (v) {
> +				(void)fent_to_name(&f, &flist[FT_DIR], dfep);
> +				printf("%d/%d: rename - no filename from %s\n",
> +					procid, opno, f.path);
> +			}
> +			free_pathname(&newf);
> +			free_pathname(&f);
> +			return;
>  		}
> -		free_pathname(&newf);
> -		free_pathname(&f);
> -		return;
>  	}
> -	e = rename_path(&f, &newf) < 0 ? errno : 0;
> +
> +	e = rename_path(&f, &newf, mode) < 0 ? errno : 0;
>  	check_cwd();
> -	if (e == 0) {
> +	if (e == 0 && mode != RENAME_EXCHANGE) {

In the normal rename case, this block of code looks like it removes the
old entry from the global file list and adds the new one with an updated
parent. If the source was a directory, we also update the parent id of
the files within that directory.

Don't we need corresponding file list fixups for exchange and whiteout?
Whiteout leaves around a special device file that probably should be
accounted for in the list. Exchange looks a bit more tricky, but we
could be changing file types and/or parent inodes there too. I.e.,
consider an exchange of a regular file and symlink under two different
parent dirs.

Brian

>  		int xattr_counter = fep->xattr_counter;
>  
>  		if (flp - flist == FT_DIR) {
> @@ -4273,12 +4341,13 @@ rename_f(int opno, long r)
>  		add_to_flist(flp - flist, id, parid, xattr_counter);
>  	}
>  	if (v) {
> -		printf("%d/%d: rename %s to %s %d\n", procid, opno, f.path,
> +		printf("%d/%d: rename(%s) %s to %s %d\n", procid,
> +			opno, translate_renameat2_flags(mode), f.path,
>  			newf.path, e);
>  		if (e == 0) {
> -			printf("%d/%d: rename del entry: id=%d,parent=%d\n",
> +			printf("%d/%d: rename source entry: id=%d,parent=%d\n",
>  				procid, opno, fep->id, fep->parent);
> -			printf("%d/%d: rename add entry: id=%d,parent=%d\n",
> +			printf("%d/%d: rename target entry: id=%d,parent=%d\n",
>  				procid, opno, id, parid);
>  		}
>  	}
> @@ -4287,6 +4356,29 @@ rename_f(int opno, long r)
>  }
>  
>  void
> +rename_f(int opno, long r)
> +{
> +	do_renameat2(opno, r, 0);
> +}
> +void
> +rnoreplace_f(int opno, long r)
> +{
> +	do_renameat2(opno, r, RENAME_NOREPLACE);
> +}
> +
> +void
> +rexchange_f(int opno, long r)
> +{
> +	do_renameat2(opno, r, RENAME_EXCHANGE);
> +}
> +
> +void
> +rwhiteout_f(int opno, long r)
> +{
> +	do_renameat2(opno, r, RENAME_WHITEOUT);
> +}
> +
> +void
>  resvsp_f(int opno, long r)
>  {
>  	int		e;
> -- 
> 1.8.3.1
> 
> -- 
> kaixuxia



[Index of Archives]     [XFS Filesystem Development (older mail)]     [Linux Filesystem Development]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux RAID]     [Linux SCSI]


  Powered by Linux