On Mon, 2019-08-26 at 14:31 -0500, Eric Sandeen wrote: Finally got time to start looking at this. > On 8/26/19 2:19 PM, Eric Sandeen wrote: > > > case Opt_biosize: > > > - if (match_kstrtoint(args, 10, &iosize)) > > > + if (suffix_kstrtoint(param->string, 10, &iosize)) > > > return -EINVAL; > > > - *iosizelog = ffs(iosize) - 1; > > > + ctx->iosizelog = ffs(iosize) - 1; > > > break; > > > case Opt_grpid: > > > + if (result.negated) > > > + mp->m_flags &= ~XFS_MOUNT_GRPID; > > > + else > > > + mp->m_flags |= XFS_MOUNT_GRPID; > > > + break; > > Is there any real advantage to this "fsparam_flag_no" / negated > > stuff? > > I don't see any other filesystem using it (yet) and I'm not totally > > convinced > > that this is any better, more readable, or more efficient than just > > keeping > > the "Opt_nogrpid" stuff around. Not a dealbreaker but just > > thinking out > > loud... seems like this interface was a solution in search of a > > problem? > > Also, at least as of this patch, it seems broken: > > [xfstests-dev]# mount -o noikeep /dev/pmem0p1 /mnt/test > mount: mount /dev/pmem0p1 on /mnt/test failed: Unknown error 519 > > <dmesg shows nothing> > > [xfstests-dev]# mount -o ikeep /dev/pmem0p1 /mnt/test > mount: wrong fs type, bad option, bad superblock on /dev/pmem0p1, > missing codepage or helper program, or other error > > In some cases useful info is found in syslog - try > dmesg | tail or so. > [xfstests-dev]# dmesg | tail -n 1 > [ 282.281557] XFS: Unexpected value for 'ikeep' Bizare, everything I'm looking at says this case shouldn't trigger! Think I'm going to need to burn some grey cells on this, ;) Ian