[PATCH 0/3] Minor cleanups

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



While digging around xfs' buf code I spotted a couple of cleanup candidates
which resulted in this patch. It should hopefully make the code easier to inspect
by reducing the 'hops' to the actual implementation of buffer submission. 

Nikolay Borisov (3):
  xfs: Use __xfs_buf_submit everywhere
  xfs: Rename __xfs_buf_submit to xfs_buf_submit
  xfs: Opencode and remove DEFINE_SINGLE_BUF_MAP

 fs/xfs/xfs_buf.c         | 16 +++++++++-------
 fs/xfs/xfs_buf.h         | 16 ++++------------
 fs/xfs/xfs_buf_item.c    |  2 +-
 fs/xfs/xfs_log_recover.c |  2 +-
 fs/xfs/xfs_trans.h       |  6 ++++--
 5 files changed, 19 insertions(+), 23 deletions(-)

-- 
2.17.1




[Index of Archives]     [XFS Filesystem Development (older mail)]     [Linux Filesystem Development]     [Linux Audio Users]     [Yosemite Trails]     [Linux Kernel]     [Linux RAID]     [Linux SCSI]


  Powered by Linux