On Wed, Jan 03, 2018 at 11:44:17AM +1100, Dave Chinner wrote: > On Fri, Dec 22, 2017 at 05:08:56PM -0800, Darrick J. Wong wrote: > > From: Darrick J. Wong <darrick.wong@xxxxxxxxxx> > > > > Rename xfs_dqcheck to xfs_dquot_verify and make it return an > > xfs_failaddr_t like every other structure verifier function. > > This enables us to check on-disk quotas in the same way that we check > > everything else. Callers are now responsible for logging errors, as > > XFS_QMOPT_DOWARN goes away. > > > > Signed-off-by: Darrick J. Wong <darrick.wong@xxxxxxxxxx> > > One minor nit: > > > @@ -2701,11 +2701,14 @@ xlog_recover_do_reg_buffer( > > item->ri_buf[i].i_len, __func__); > > goto next; > > } > > - error = xfs_dqcheck(mp, item->ri_buf[i].i_addr, > > - -1, 0, XFS_QMOPT_DOWARN, > > - "dquot_buf_recover"); > > - if (error) > > + fa = xfs_dquot_verify(mp, item->ri_buf[i].i_addr, > > + -1, 0, 0); > > + if (fa) { > > + xfs_alert(mp, > > + "dquot corrupt at %pS trying to replay into block 0x%llx", > > + fa, bp->b_bn); > > goto next; > > + } > > Alert message line too long here, just pull the indent back for > it... Ok, done. --D > Otherwise it looks good. > > Reviewed-by: Dave Chinner <dchinner@xxxxxxxxxx> > > -- > Dave Chinner > david@xxxxxxxxxxxxx > -- > To unsubscribe from this list: send the line "unsubscribe linux-xfs" in > the body of a message to majordomo@xxxxxxxxxxxxxxx > More majordomo info at http://vger.kernel.org/majordomo-info.html -- To unsubscribe from this list: send the line "unsubscribe linux-xfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html