On Tue, Dec 26, 2017 at 08:15:42PM +0300, Kirill A. Shutemov wrote: > > 28 files changed, 249 insertions(+), 240 deletions(-) > > Everything looks fine to me after quick scan, but hat's a lot of changes for > one patch... Yeah. It's pretty mechanical though. > > - if (radix_tree_exceptional_entry(page)) { > > + if (xa_is_value(page)) { > > if (!invalidate_exceptional_entry2(mapping, > > index, page)) > > ret = -EBUSY; > > invalidate_exceptional_entry? Are we going to leave the terminology here as is? That is a great question. If the page cache wants to call its value entries exceptional entries, it can continue to do that. I think there's a better name for them, but I'm not sure what it is. Right now, the page cache uses value entries to store: 1. Shadow entries (for workingset) 2. Swap entries (for shmem) 3. DAX entries I can't come up with a good name for these three things. 'nonpage' is the only thing which hasn't immediately fallen off my ideas list. But I think renaming exceptional entries in the page cache is a great idea, and I don't want to do it as part of this patch set ;-) -- To unsubscribe from this list: send the line "unsubscribe linux-xfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html