On 01/06/2017 03:11 PM, Michal Hocko wrote: > From: Michal Hocko <mhocko@xxxxxxxx> > > xfs has defined PF_FSTRANS to declare a scope GFP_NOFS semantic quite > some time ago. We would like to make this concept more generic and use > it for other filesystems as well. Let's start by giving the flag a > more generic name PF_MEMALLOC_NOFS which is in line with an exiting > PF_MEMALLOC_NOIO already used for the same purpose for GFP_NOIO > contexts. Replace all PF_FSTRANS usage from the xfs code in the first > step before we introduce a full API for it as xfs uses the flag directly > anyway. > > This patch doesn't introduce any functional change. > > Signed-off-by: Michal Hocko <mhocko@xxxxxxxx> > Reviewed-by: Brian Foster <bfoster@xxxxxxxxxx> Acked-by: Vlastimil Babka <vbabka@xxxxxxx> A nit: > --- a/include/linux/sched.h > +++ b/include/linux/sched.h > @@ -2320,6 +2320,8 @@ extern void thread_group_cputime_adjusted(struct task_struct *p, cputime_t *ut, > #define PF_FREEZER_SKIP 0x40000000 /* Freezer should not count it as freezable */ > #define PF_SUSPEND_TASK 0x80000000 /* this thread called freeze_processes and should not be frozen */ > > +#define PF_MEMALLOC_NOFS PF_FSTRANS /* Transition to a more generic GFP_NOFS scope semantic */ I don't see why this transition is needed, as there are already no users of PF_FSTRANS after this patch. The next patch doesn't remove any more, so this is just extra churn IMHO. But not a strong objection. > + > /* > * Only the _current_ task can read/write to tsk->flags, but other > * tasks can access tsk->flags in readonly mode for example > -- To unsubscribe from this list: send the line "unsubscribe linux-xfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html