On Fri, Sep 30, 2016 at 12:34:04AM -0700, Christoph Hellwig wrote: > > +/* Deferred mapping is only for real extents in the data fork. */ > > +static bool > > +xfs_bmap_is_update_needed( > > + int whichfork, > > + struct xfs_bmbt_irec *bmap) > > +{ > > + ASSERT(whichfork == XFS_DATA_FORK); > > + > > + return bmap->br_startblock != HOLESTARTBLOCK && > > + bmap->br_startblock != DELAYSTARTBLOCK; > > +} > > Passing in an argument just to assert on it seems weird. > And except for that a better name might be xfs_bmbt_is_real or similar, > and I bet we'd have other users for it as well. xfs_bmap_*map_extent are the only callers, and the only whichfork values are XFS_DATA_FORK. I might as well just tear out all those asserts since they're never going to trigger anyway. --D > > Otherwise this looks fine to me: > > Reviewed-by: Christoph Hellwig <hch@xxxxxx> -- To unsubscribe from this list: send the line "unsubscribe linux-xfs" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html