Hi Alexander, aahringo@xxxxxxxxxx wrote on Fri, 3 Jun 2022 22:01:38 -0400: > Hi, > > On Fri, Jun 3, 2022 at 2:34 PM Miquel Raynal <miquel.raynal@xxxxxxxxxxx> wrote: > > > > The current enum is wrong. A device can either be an RFD, an RFD-RX, an > > RFD-TX or an FFD. If it is an FFD, it can also be a coordinator. While > > defining a node type might make sense from a strict software point of > > view, opposing node and coordinator seems meaningless in the ieee > > 802.15.4 world. As this enumeration is not used anywhere, let's just > > drop it. We will in a second time add a new "node type" enumeration > > which apply only to nodes, and does differentiates the type of devices > > mentioned above. > > > > First you cannot say if this is not used anywhere else. Mmmh, that's tricky, I really don't see how that might be a problem because there is literally nowhere in the kernel that uses this type, besides ieee802154_setup_sdata() which would just BUG() if this type was to be used. So I assumed it was safe to be removed. > Second I have > a different opinion here that you cannot just "switch" the role from > RFD, FFD, whatever. I agree with this, and that's why I don't understand this enum. A device can either be a NODE (an active device) or a MONITOR (a passive device) at a time. We can certainly switch from one to another at run time. A NODE can be either an RFD or an FFD. That is a static property which cannot change. However being a coordinator is just an additional property of a NODE which is of type FFD, and this can change over time. So I don't get what having a coordinator interface would bring. What was the idea behind its introduction then? > You are mixing things here with "role in the network" and what the > transceiver capability (RFD, FFD) is, which are two different things. I don't think I am, however maybe our vision differ on what an interface should be. > You should use those defines and the user needs to create a new > interface type and probably have a different extended address to act > as a coordinator. Can't we just simply switch from coordinator to !coordinator (that's what I currently implemented)? Why would we need the user to create a new interface type *and* to provide a new address? Note that these are real questions that I am asking myself. I'm fine adapting my implementation, as long as I get the main idea. Thanks, Miquèl