Hello Dave, Jakub. An update from ieee802154 for your *net-next* tree. There is more ongoing in ieee802154 than usual. This will be the first pull request for this cycle, but I expect one more. Depending on review and rework times. Pavel Skripkin ported the atusb driver over to the new USB api to avoid unint problems as well as making use of the modern api without kmalloc() needs in he driver. Miquel Raynal landed some changes to ensure proper frame checksum checking with hwsim, documenting our use of wake and stop_queue and eliding a magic value by using the proper define. David Girault documented the address struct used in ieee802154. regards Stefan Schmidt The following changes since commit 8aaaf2f3af2ae212428f4db1af34214225f5cec3: Merge git://git.kernel.org/pub/scm/linux/kernel/git/netdev/net (2022-01-09 17:00:17 -0800) are available in the Git repository at: git://git.kernel.org/pub/scm/linux/kernel/git/sschmidt/wpan-next.git tags/ieee802154-for-davem-2022-02-10 for you to fetch changes up to 02b2a91c6f0d57df687e666b475849a54f295a12: net: ieee802154: Provide a kdoc to the address structure (2022-02-01 21:03:48 +0100) ---------------------------------------------------------------- David Girault (1): net: ieee802154: Provide a kdoc to the address structure Miquel Raynal (3): net: ieee802154: hwsim: Ensure frame checksum are valid net: ieee802154: Use the IEEE802154_MAX_PAGE define when relevant net: mac802154: Explain the use of ieee802154_wake/stop_queue() Pavel Skripkin (1): ieee802154: atusb: move to new USB API drivers/net/ieee802154/atusb.c | 186 +++++++++++-------------------- drivers/net/ieee802154/mac802154_hwsim.c | 2 +- include/net/cfg802154.h | 10 ++ include/net/mac802154.h | 12 ++ net/ieee802154/nl-phy.c | 4 +- 5 files changed, 92 insertions(+), 122 deletions(-)