Search Linux Wireless

Re: [PATCH 01/20] wl18xx: update default mac/phy parameters

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

 



On Tue, 2012-11-27 at 08:44 +0200, Arik Nemtsov wrote:
> From: Ido Reis <idor@xxxxxx>
> 
> Update mac/phy paramters according to the default HP SISO boards.
> 
> Signed-off-by: Ido Reis <idor@xxxxxx>
> Signed-off-by: Arik Nemtsov <arik@xxxxxxxxxx>
> ---
>  drivers/net/wireless/ti/wl18xx/conf.h |   17 +++++++++++------
>  drivers/net/wireless/ti/wl18xx/main.c |    7 ++++---
>  2 files changed, 15 insertions(+), 9 deletions(-)
> 
> diff --git a/drivers/net/wireless/ti/wl18xx/conf.h b/drivers/net/wireless/ti/wl18xx/conf.h
> index 4d426cc..f020c1c 100644
> --- a/drivers/net/wireless/ti/wl18xx/conf.h
> +++ b/drivers/net/wireless/ti/wl18xx/conf.h
> @@ -23,20 +23,21 @@
>  #define __WL18XX_CONF_H__
>  
>  #define WL18XX_CONF_MAGIC	0x10e100ca
> -#define WL18XX_CONF_VERSION	(WLCORE_CONF_VERSION | 0x0003)
> +#define WL18XX_CONF_VERSION	(WLCORE_CONF_VERSION | 0x0004)
>  #define WL18XX_CONF_MASK	0x0000ffff
>  #define WL18XX_CONF_SIZE	(WLCORE_CONF_SIZE + \
>  				 sizeof(struct wl18xx_priv_conf))
>  
>  #define NUM_OF_CHANNELS_11_ABG 150
>  #define NUM_OF_CHANNELS_11_P 7
> -#define WL18XX_NUM_OF_SUB_BANDS 9
>  #define SRF_TABLE_LEN 16
>  #define PIN_MUXING_SIZE 2
> +#define NUM_OF_TRACE_LOSS_GAPS_TX 10
> +#define NUM_OF_TRACE_LOSS_GAPS_RX 18

I'll s/NUM_OF/WL18XX/ here when I apply.


> diff --git a/drivers/net/wireless/ti/wl18xx/main.c b/drivers/net/wireless/ti/wl18xx/main.c
> index e71e2cf..30222cb 100644
> --- a/drivers/net/wireless/ti/wl18xx/main.c
> +++ b/drivers/net/wireless/ti/wl18xx/main.c

[...]

> @@ -525,13 +524,15 @@ static struct wl18xx_priv_conf wl18xx_default_priv_conf = {
>  		.enable_tx_low_pwr_on_siso_rdl	= 0x00,
>  		.rx_profile			= 0x00,
>  		.pwr_limit_reference_11_abg	= 0xc8,
> +		.pwr_limit_reference_11p	= 0xc8,
>  		.psat				= 0,
>  		.low_power_val			= 0x00,
> -		.med_power_val			= 0x0a,
> -		.high_power_val			= 0x1e,
> +		.med_power_val			= 0x0A,
> +		.high_power_val			= 0x11,

The change from 0x0a to 0x0A shouldn't be here.  I'll remove it.

--
Luca.

--
To unsubscribe from this list: send the line "unsubscribe linux-wireless" in
the body of a message to majordomo@xxxxxxxxxxxxxxx
More majordomo info at  http://vger.kernel.org/majordomo-info.html


[Index of Archives]     [Linux Host AP]     [ATH6KL]     [Linux Wireless Personal Area Network]     [Linux Bluetooth]     [Linux Netdev]     [Kernel Newbies]     [Linux Kernel]     [IDE]     [Git]     [Netfilter]     [Bugtraq]     [Yosemite Hiking]     [MIPS Linux]     [ARM Linux]     [Linux RAID]

  Powered by Linux