On Wed, 2012-10-03 at 15:53 +0200, Goldenshtein, Victor wrote: > >> @@ -720,6 +728,8 @@ enum nl80211_commands { > >> > >> NL80211_CMD_CH_SWITCH_NOTIFY, > >> > >> + NL80211_CMD_AP_CH_SWITCH, > >> + > >> NL80211_CMD_RADAR_DETECT, > >> > >> NL80211_CMD_DFS_ENABLE_TX, > > > > Ahem. > > > > just thought to put the channel switch stuff together. > don't might to move it down. Yeah but you can *never* insert anything in the middle. > >> * @NL80211_FEATURE_DFS: Radar detection is supported in the HW/driver. > >> + * @NL80211_FEATURE_AP_CH_SWITCH: This driver supports AP channel switch. > > > > I have a nagging feeling I keep asking this, but what's the point of > > radar detection without channel switch? Or is it the other way around > > that's interesting? Maybe should verify that if you have DFS you also > > have chanswitch? > > one might support a channel switch without DFS, but the one who sets > the "NL80211_FEATURE_DFS" must support channel switch. > I don't might to check both these flags, but then I think it would be > cleaner (more readable) to leave the "dfs_supported" flag. > something like: > bool dfs_supported = ((local->hw.wiphy->features & NL80211_FEATURE_DFS) && > (local->hw.wiphy->features & NL80211_FEATURE_AP_CH_SWITCH)); fair enough. makes sense for p2p I guess > >> + * @block_tx: Indicates whether transmission must be blocked before the > >> + * scheduled channel switch, as indicated by the AP. > > Bogus documentation. > > can you please elaborate on this one. for example the only thing I quoted above now ... clearly can't be right > note that it's almost identical to "ieee80211_channel_switch" struct, and that's the problem johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html