Hm, seems I missed this before: > --- a/include/net/cfg80211.h > +++ b/include/net/cfg80211.h > @@ -498,6 +498,7 @@ enum station_parameters_apply_mask { > * @plink_action: plink action to take > * @plink_state: set the peer link state for a station > * @ht_capa: HT capabilities of station > + * @vht_capa: VHT capabilities of station > * @uapsd_queues: bitmap of queues configured for uapsd. same format > * as the AC bitmap in the QoS info field > * @max_sp: max Service Period. same format as the MAX_SP in the > @@ -517,6 +518,7 @@ struct station_parameters { > u8 plink_action; > u8 plink_state; > struct ieee80211_ht_cap *ht_capa; > + struct ieee80211_vht_cap *vht_capa; I don't think this should be part of this particular patch? Shouldn't there be a cfg80211/nl80211 patch to allow hostapd to set this information when adding a station, like for HT, and then that patch introduces this struct member? > + * @vht_cap: VHT capabilities of this STA; Not restricting any capabilities > + * of remote STA. Taking as is. Thanks :) > - 2 + sizeof(struct ieee80211_vht_capabilities) + /* VHT */ > + 2 + sizeof(struct ieee80211_vht_cap) + /* VHT */ Maybe all this renaming (and the ieee80211.h change) could be a separate patch? Then this would be easier to read overall I think. > +#include <linux/ieee80211.h> > +#include <linux/export.h> export.h isn't needed here (yet) johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html