On Fri, Jul 27, 2012 at 2:16 PM, Johannes Berg <johannes@xxxxxxxxxxxxxxxx> wrote: > From: Michal Kazior <michal.kazior@xxxxxxxxx> > > Split functionality for further reuse. > > Will prevent code duplication when channel context > channel_type merging is introduced. > > Signed-off-by: Michal Kazior <michal.kazior@xxxxxxxxx> > Signed-off-by: Johannes Berg <johannes.berg@xxxxxxxxx> > --- > + > +bool ieee80211_set_channel_type(struct ieee80211_local *local, > + struct ieee80211_sub_if_data *sdata, > + enum nl80211_channel_type chantype) > +{ > + enum nl80211_channel_type superchan; > + enum nl80211_channel_type compatchan = NL80211_CHAN_NO_HT; > + no need to initialize compatchan. > + superchan = ieee80211_get_superchan(local, sdata); > + if (!ieee80211_channel_types_are_compatible(superchan, chantype, > + &compatchan)) > + return false; > + as it should be assigned here. Eliad. -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html