On Wed, 2012-06-27 at 11:26 +0200, Johannes Berg wrote: > diff --git a/drivers/net/wireless/ti/wlcore/main.c > b/drivers/net/wireless/ti/wlcore/main.c > index 1156e3f..747a997 100644 > --- a/drivers/net/wireless/ti/wlcore/main.c > +++ b/drivers/net/wireless/ti/wlcore/main.c > @@ -5321,6 +5321,7 @@ int __devinit wlcore_probe(struct wl1271 *wl, > struct platform_device *pdev) > goto out_free_hw; > } > > +#ifdef CONFIG_PM > ret = enable_irq_wake(wl->irq); > if (!ret) { > wl->irq_wake_enabled = true; > @@ -5334,6 +5335,7 @@ int __devinit wlcore_probe(struct wl1271 *wl, > struct platform_device *pdev) > WL1271_RX_FILTER_MAX_PATTERN_SIZE; > } > } > +#endif > disable_irq(wl->irq); I'm not the biggest fan of #ifdef's in the middle of functions, but I guess it's clean enough here. Maybe we split this out to a separate function that can be #ifdef'ed entirely. In any case, for the wlcore part: Acked-by: Luciano Coelho <coelho@xxxxxx> -- Cheers, Luca. -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html