On Sat, 2011-10-08 at 18:00 -0500, Larry Finger wrote: > On 10/08/2011 05:38 PM, Joe Perches wrote: > > On Sat, 2011-10-08 at 17:28 -0500, Larry Finger wrote: > >> The kernel now contains library routines to establish crc8 tables and > >> to calculate the appropriate sums. Use them for ssb. > > [] > >> --- wireless-testing-new.orig/drivers/ssb/pci.c > > [] > >> +static inline void ltoh16_buf(u16 *buf, unsigned int size) > > > > Perhaps a rename and use le16_to_cpup? > > > >> +static inline void htol16_buf(u16 *buf, unsigned int size) > > > > and cpu_to_le16p? > > I'm sorry, but I don't see any advantage to using a pointer version here. Please > enlighten me. It's just a naming consistency thing, you already are using a pointer version, and maybe this should go into byteorder.h inline void array_cpu_to_le16p(u16 *p, size_t size) { while (size) { cpu_to_le16p(p++); size--; } } -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html