On Tue, Sep 27, 2011 at 14:50, Johannes Berg <johannes@xxxxxxxxxxxxxxxx> wrote: > On Mon, 2011-09-26 at 13:54 +0300, Arik Nemtsov wrote: > >> +/* >> + * TDLS capabililites to be enabled in the 5th byte of the >> + * @WLAN_EID_EXT_CAPABILITY information element >> + */ >> +#define WLAN_EXT_CAPA_TDLS_ENABLED BIT(5) >> +#define WLAN_EXT_CAPA_TDLS_PROHIBITED BIT(6) > > Would it be useful to have the IE declared as a struct somewhere? It's really just a bit-mask, and a variable length one as it is. But I'll change the name to make it more palatable. Something like WLAN_EXT_CAPA5_TDLS_ENABLED :) > > >> +static int >> +ieee80211_prep_tdls_encap_data(struct wiphy *wiphy, struct net_device *dev, >> + u8 *peer, u8 action_code, u8 dialog_token, >> + u16 status_code, struct sk_buff *skb) > > All the code addition here makes me wonder if it'd be useful to move it > into a new tdls.c file and just call the right hooks from cfg.c? the cfg > file is pretty large already ... tdls wouldn't be huge, but still might > make sense? As discussed on IRC, this code is pretty much stateless, and it's not a lot of code. We agreed we can keep it in cfg.c for now. Arik -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html