On Wed, 2011-08-10 at 17:48 +0200, Alexander Simon wrote: > Am Mittwoch, den 10.08.2011, 15:53 +0200 schrieb Johannes Berg: > > On Mon, 2011-08-08 at 14:04 +0200, Alexander Simon wrote: > > > > > +struct cfg80211_bss *cfg80211_get_bss_ht(struct wiphy *wiphy, > > > + struct ieee80211_channel *channel, > > > + const u8 *bssid, > > > + const u8 *ssid, size_t ssid_len, > > > + u16 capa_mask, u16 capa_val, > > > + enum nl80211_channel_type channel_type); > > > > indentation? Also, you really need kernel-doc for this. > Pardon me, but I don't know what you mean... I just browsed > Documentation/networking. Could you point me the exact file, please? Documentation/kernel-doc-nano-HOWTO.txt maybe? > > You've got to be kidding, if you export it you really need to give it a > > decent name. Besides, you don't have to export it in this patch. > I intended to export this instead of writing ieee80211_can_use_ext_chan > first. > Ok, to summarize this: I should use this instead of my own > ieee80211_can_use_ext_chan in mac80211 (as in your reply in 4/4), but > when I export this I need to rename it. Does cfg80211_can_use_ext_chan > sound well? Ok but then I guess you forgot to remove the export? Yeah, please rename it and export it for mac80211, that seems fine. > > I don't like the semantics of this. Why is NO_HT indicating "don't care > > about HT"? How then do you really find a NO_HT BSS? > > > > Also, this raises a more fundamental question -- didn't you earlier say > > you wanted to be able to connect with any IBSS, even non-HT ones, but > > now it must match? > This is only used for fixed channel mode. As we would only join a > matching HT mode, I have to pass it here. > How about second parameter, "bool match_ht"? Ahh, ok, that explains it, sorry for the confusion. johannes -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html