On 06/06/2011 01:32 PM, RafaÅ MiÅecki wrote: > 2011/6/6 Hauke Mehrtens <hauke@xxxxxxxxxx>: >> +config BCMA_PCICORE_HOSTMODE >> + bool "Hostmode support for BCMA PCI core" >> + depends on BCMA_DRIVER_MIPS >> + help >> + PCIcore hostmode operation (external PCI bus). > > I think you started to use BCMA_DRIVER_corename. Could you stick to it > (one schema), please? Maybe just > BCMA_DRIVER_PCI_HOSTMODE > ? > Yes sounds better. > >> +#ifdef CONFIG_BCMA_PCICORE_HOSTMODE >> + pc->hostmode = bcma_pcicore_is_in_hostmode(pc); >> + if (pc->hostmode) >> + bcma_pcicore_init_hostmode(pc); >> +#endif /* CONFIG_BCMA_PCICORE_HOSTMODE */ >> + if (!pc->hostmode) >> + bcma_pcicore_serdes_workaround(pc); > > Does it make sense to init hostmode PCI like clientmode if we just > disable CONFIG_BCMA_PCICORE_HOSTMODE? > > I think we should always check if core is host or client mode and use > correct initialization only. We should not init it as clientmode just > because we do not have driver for host mode. Yes we should not initialize a host mode pci core with client init code as it will break my device. ;-) I will place bcma_pcicore_is_in_hostmode() into the normal PCI driver code so it is available all the time. > > >> diff --git a/drivers/bcma/driver_pci_host.c b/drivers/bcma/driver_pci_host.c >> new file mode 100644 >> index 0000000..b52c6c9 >> --- /dev/null >> +++ b/drivers/bcma/driver_pci_host.c >> @@ -0,0 +1,44 @@ >> +/* >> + * Broadcom specific AMBA >> + * PCI Core > > Please rename "PCI Core", add something about hostmode. > Missed that while copy and past. Hauke -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html