2011/5/7 Hauke Mehrtens <hauke@xxxxxxxxxx>: > On 05/07/2011 06:51 PM, RafaÅ MiÅecki wrote: >> 2011/5/7 Hauke Mehrtens <hauke@xxxxxxxxxx>: >>> On 05/07/2011 06:23 PM, RafaÅ MiÅecki wrote: >>>> 2011/5/7 Hauke Mehrtens <hauke@xxxxxxxxxx>: >>>>> On 05/05/2011 11:59 PM, RafaÅ MiÅecki wrote: >>>>>> Cc: Greg KH <greg@xxxxxxxxx> >>>>>> Cc: Michael BÃsch <mb@xxxxxxxxx> >>>>>> Cc: Larry Finger <Larry.Finger@xxxxxxxxxxxx> >>>>>> Cc: George Kashperko <george@xxxxxxxxxxx> >>>>>> Cc: Arend van Spriel <arend@xxxxxxxxxxxx> >>>>>> Cc: linux-arm-kernel@xxxxxxxxxxxxxxxxxxx >>>>>> Cc: Russell King <rmk@xxxxxxxxxxxxxxxx> >>>>>> Cc: Arnd Bergmann <arnd@xxxxxxxx> >>>>>> Cc: Andy Botting <andy@xxxxxxxxxxxxxxx> >>>>>> Cc: linuxdriverproject <devel@xxxxxxxxxxxxxxxxxxxxxx> >>>>>> Cc: linux-kernel@xxxxxxxxxxxxxxx <linux-kernel@xxxxxxxxxxxxxxx> >>>>>> Signed-off-by: RafaÅ MiÅecki <zajec5@xxxxxxxxx> >>>>>> --- >>>>>> V2: Rename to axi >>>>>>   Use DEFINE_PCI_DEVICE_TABLE in bridge >>>>>>   Make use of pr_fmt and pr_* >>>>>>   Store core class >>>>>>   Rename bridge to not b43 specific >>>>>>   Replace magic 0x1000 with BCMAI_CORE_SIZE >>>>>>   Remove some old "ssb" names and defines >>>>>>   Move BCMAI_ADDR_BASE def >>>>>>   Add drvdata field >>>>>> V3: Fix reloading (kfree issue) >>>>>>   Add 14e4:0x4331 >>>>>>   Fix non-initialized struct issue >>>>>>   Drop useless inline functions wrappers for pci core drv >>>>>>   Proper pr_* usage >>>>>> V3.1: Include forgotten changes (pr_* and include related) >>>>>>   Explain why we dare to implement empty release function >>>>>> V4: Add ABI documentation >>>>>>   Move struct device to wrapper and alloc it dynamically >>>>>>   checkpatch.pl pointed fixes >>>>>> V5: Rename to bcma, AXI was really bad name >>>>>>   Use EXPORT_SYMBOL_GPL >>>>>>   Set pci driver fields in one place >>>>>>   Drop unlikely >>>>>>   Use BCMA_CORE_SIZE for calc in awrite32 >>>>>>   Add README >>>>>>   Fix compilation (delay.h) >>>>>> --- >>>>>> ÂDocumentation/ABI/testing/sysfs-bus-bcma  Â|  31 ++ >>>>>> Âdrivers/Kconfig               |  Â2 + >>>>>> Âdrivers/Makefile              Â|  Â1 + >>>>>> Âdrivers/bcma/Kconfig            Â|  33 +++ >>>>>> Âdrivers/bcma/Makefile            |  Â7 + >>>>>> Âdrivers/bcma/README             |  18 ++ >>>>>> Âdrivers/bcma/TODO              |  Â3 + >>>>>> Âdrivers/bcma/bcma_private.h         |  31 ++ >>>>>> Âdrivers/bcma/core.c             |  51 ++++ >>>>>> Âdrivers/bcma/driver_chipcommon.c      Â|  87 ++++++ >>>>>> Âdrivers/bcma/driver_chipcommon_pmu.c    Â| Â134 +++++++++ >>>>>> Âdrivers/bcma/driver_pci.c          | Â163 +++++++++++ >>>>>> Âdrivers/bcma/host_pci.c           | Â196 +++++++++++++ >>>>>> Âdrivers/bcma/main.c             | Â271 ++++++++++++++++++ >>>>>> Âdrivers/bcma/scan.c             | Â392 +++++++++++++++++++++++++++ >>>>>> Âdrivers/bcma/scan.h             |  56 ++++ >>>>>> Âinclude/linux/bcma/bcma.h          | Â232 ++++++++++++++++ >>>>>> Âinclude/linux/bcma/bcma_driver_chipcommon.h | Â297 ++++++++++++++++++++ >>>>>> Âinclude/linux/bcma/bcma_driver_pci.h    Â|  89 ++++++ >>>>>> Âinclude/linux/bcma/bcma_regs.h       Â|  34 +++ >>>>>> Âinclude/linux/mod_devicetable.h       |  17 ++ >>>>>> Âscripts/mod/file2alias.c          Â|  22 ++ >>>>>> Â22 files changed, 2167 insertions(+), 0 deletions(-) >>>>>> Âcreate mode 100644 Documentation/ABI/testing/sysfs-bus-bcma >>>>>> Âcreate mode 100644 drivers/bcma/Kconfig >>>>>> Âcreate mode 100644 drivers/bcma/Makefile >>>>>> Âcreate mode 100644 drivers/bcma/README >>>>>> Âcreate mode 100644 drivers/bcma/TODO >>>>>> Âcreate mode 100644 drivers/bcma/bcma_private.h >>>>>> Âcreate mode 100644 drivers/bcma/core.c >>>>>> Âcreate mode 100644 drivers/bcma/driver_chipcommon.c >>>>>> Âcreate mode 100644 drivers/bcma/driver_chipcommon_pmu.c >>>>>> Âcreate mode 100644 drivers/bcma/driver_pci.c >>>>>> Âcreate mode 100644 drivers/bcma/host_pci.c >>>>>> Âcreate mode 100644 drivers/bcma/main.c >>>>>> Âcreate mode 100644 drivers/bcma/scan.c >>>>>> Âcreate mode 100644 drivers/bcma/scan.h >>>>>> Âcreate mode 100644 include/linux/bcma/bcma.h >>>>>> Âcreate mode 100644 include/linux/bcma/bcma_driver_chipcommon.h >>>>>> Âcreate mode 100644 include/linux/bcma/bcma_driver_pci.h >>>>>> Âcreate mode 100644 include/linux/bcma/bcma_regs.h >>>>>> >>>>> Hi, >>>>> >>>>> An entry in the MAINTAINERS file would be nice to find the right >>>>> addresses to send patches to. >>>> >>>> Will do, thanks. Should I put some ML for this driver? >>>> netdev@xxxxxxxxxxxxxxx? linux-wireless@xxxxxxxxxxxxxxx? So far there >>>> are no net drivers for BCMA. Probably b43 will be the first (or >>>> brcm80211). >>>> >>> There is a Ethernet core used on embedded devices with this bus and >>> George wrote a driver for the first version of this bus implementation, >>> he send to the ML. Most user will use this with some wireless devices so >>> I would add linux-wireless@xxxxxxxxxxxxxxxx Why does ssb uses netdev ML? >> >> Thanks, I didn't know about this ethernet driver. Have to check it! >> Where was this published? Do you have a thread name? > > I think he haven't send it to the mailing list, there is a link [0] in > some Ticket [1] at OpenWrt. This driver was derived from source code > Braodcom have published, but not under a GPL compatible license. It will > be nice if Braodcom would allow us to publish a driver under the terms > of the GPL for the Ethernet core based on their driver, without writing > a full spec of the driver like it was done for b43. OK, I'll stay away from this driver for now (license). >> I'm not sure if we want linux-wireless to be ML, if we already have >> some Ethernet driver. Some network-general ML makes more sense then. >> Maybe netdev would be better. > > Some of the embedded devices also have a USB core on the BCMA bus and a > pci(e) host controller to connect other pci(e) devices. As most of the > patches for ssb came from the wireless guys and I do not thing this will > be different for bcma, I thing the wireless mailing list is the correct > place. Ups, yeah, you're right. I didn't think about USB, V90, PCI(e), etc... I think situations linux-wireless as most active or linux-kernel as most generic should be used. I think I'm fine with linux-wireless. -- RafaÅ -- To unsubscribe from this list: send the line "unsubscribe linux-wireless" in the body of a message to majordomo@xxxxxxxxxxxxxxx More majordomo info at http://vger.kernel.org/majordomo-info.html